Android problème de configuration

#1

Bonjour à tous la version du cours est 3.2.1 mais celle du download est
3.3 et les question très différente, il ne vois pas missing SDK et demande
pas de l’installer mais mentionne que certaine filière sont verrouiller par mac
et entre autre d’aller dans sécurité et mac pour permettre ces filières d’être downloder
demande de faire un restart pour changé les paramètre, puis demande
notre mot de passe pour déverrouiller le système, aussi la possibilité de
crocher une option que le cours ne mentionne pas ‘‘virtuel’’ et le programme
d’installation RECOMMANDE de faire ce choix et de l’installer,
en d’autre terme plus compliquer que le simple installation proposer
par le cours :thinking:

Avec quelque essaie on peut réussir, et on passe à la prochaine
lesson créé sa première application. Start a new Android Studio Projet
:roll_eyes: oops rien de pareille, une page d’icon plusieurs choix d’activity
de sélectionner en partant le projet Phone and tablet or few more choice.
J’ai essayer plusieurs choix et simplement je ferme tout en attendant
des nouvelle comment poursuivre la création du premier app. :persevere:

#2

Bonjour,

La version 3.3 est toute récente (avant-hier c’était encore la version 3.2.1)
À mon avis, le plus simple est de télécharger la version 3.2.1 dans les archives à l’adrese https://developer.android.com/studio/archive

Cordialement

#3

Bonjour,

Pour ma part j’ai téléchargé la version 3.2.1 et cela fonctionne bien.
Je pense que dans un 1er temps c’est très bien et permet d’être bien en phase avec le cours.

Bonne journée

#4

Hello,

Pas de panique.
En fait les pages de création de projet sont simplement inversées.
Il faut d’abord sélectionner l’activité et ensuite compléter les champs, (nom d’application etc…)

Sur la première page, dans l’onglet “Phone and Tablet” tu sélectionnes “Empty Activity” puis tu cliques sur “Next”
Sur l’écran suivant tu complètes les champs comme indiqué par Maxime dans la video.
Il y a 2 petites différences:

  • le choix de l’API a utiliser est en bas
  • le choix du Language ne se fait plus par checkbox mais par menu déroulant. Kotlin étant maintenant sélectionné par défaut il n’y a rien a faire a ce niveau.

Il y a 2 checkbox en bas de page, tu les laisses vide.
Puis tu cliques sur Finish et ton projet va se créer.

1 Like
#5

Effectivement la version 3.3 vient tout juste de sortir et j’enregistre les vidéos depuis le mois de Novembre et j’utilisais donc la 3.2.1

Je viens de télécharger la nouvelle version et je vais regarder ce qui a changé, je referai les vidéos concernées au plus vite.

Désolé @aucrobert pour la confusion, je ne m’attendais pas à de tels changements pour une mise à jour mineure de 3.2 en 3.3.

Je n’aurai accès au studio d’enregistrement que la semaine prochaine mes les vidéos arriveront assez vite après ça.

#6

J’ai voulu mettre Android Studio à jour, je me suis retrouvé en 3.3, et je n’ai pas galéré 5 minutes. Je me rappelle, dans le passé, avoir ramé avec une mise à jour qui fichait Gradle en l’air, il n’y avait pas moyens de le mettre à jour aussi, et il ne marchait plus même mis à jour malgré tous les Sync with file system et les modifs dans les fichiers de config de Gradle, et tous les bons conseils trouvé sur Stackoverflow. Là, pas d’affolement, juste un peu d’adaptation. Vivement qu’on en arrive à la gestion des intents.

#7

Hein ? Je viens d’installer Android Studio 3.3. C’est Java qui est sélectionné à la première utilisation, dans le menu déroulant. Par la suite, il conserve par défaut le langage choisi dans le projet précédent.

1 Like
#8

Ah! Moi j’ai eu Kotlin au premier lancement, mais surement car j’avais déjà ouvert des projets Kotlin avec l’ancienne version alors.

Sorry, ça me paraissait logique qu’ils préconisent Kotlin maintenant, mais apparemment toujours pas :sweat_smile:

Merci pour la correction.

#9

Bonjour,

je viens de refaire plusieurs enregistrements de vidéos avec la 3.3 et je les ai mis à la place des anciens sur le cours vidéo. La plupart des soucis se situaient dans le mini cours de 1h.

Si vous voyez d’autres problèmes que j’aurais manqué, tenez-moi au courant et je les referai aussi.

Bonne formation!

#10

Bonjour Maxime,

Je viens de commencer la partie 3.2 du cours et Android studio (3.3) ne reconnais pas “ApprentissageKotlin” comme projet à part entière… Du coup, impossible de l’exécuter depuis Android studio :disappointed:

J’ai pas IntelliJ sous la main pour voir si il s’ouvre bien avec…

Jc

#11

Salut jc,

je viens de tester avec Android Studio 3.3 et il ouvre et exécute sans aucun problème le projet.
Tu as bien ouvert le dossier entier “ApprentissageKotlin” et non un des fichiers à l’intérieur ?

Est-ce une mise à jour de Android studio ou une installation neuve ?
Pour ma part j’ai fait une installation neuve avec les plugins standards.
Voici à quoi ça ressemble chez moi :

  • Etape 1 : Il faut cliquer sur le bouton play en haut du fichier
  • Etape 2 : le nom de fichier doit apparaître en haut à droite en grisé (config de lancement temporaire)

D’autres personnes ont le même problème ?

#12

Hi maxime,
Yes, même problème. J’ai rapatrié et ouvert le projet ApprentissageKotlin et je me trouve dans la même situation que jcbremond. Je n’ai pas de bouton play (étape 1) pour lancer l’appli et la fenêtre de l’étape 2 montre un addconfiguration… J’ai ouvert le projet correctement le dossier entier et non les fichiers qu’il contient.

#13

Bonjour à tous,

Oui, j’ouvre bien le dossier entier et j’ai testé sur 2 machines différentes, une avec une fresh install de la 3.3 et l’autre avec un android studio régulièrement updaté et même symptômes…
Bizarre car avec un projet kotlin “standard” cela fonctionne …

my 2 cts.
Jc.

#14

Donc en créant un projet normal android et en mettant les fichiers du cours dedans, tu parviens à les exécuter ?

#15

En fait le problème vient du fait que l’archive contient un dossier avec des fichiers src kotlin et en aucun cas un projet valide …
Android studio sait bien éditer les .kt mais cela en reste là… il ne sais pas quoi en faire (Idem pour IntelliJ) …

Jc.

#16

En effet, lors du coaching de groupe hier nous avons approfondi ce soucis et nous avons fait la même constatation.
Mon fichier .gitignore bloquait l’ajout du fichier .iml et du dossier .idea donc ils sont sur mon ordinateur mais ne sont pas présents sur le dépôt git.
J’ai corrigé aujourd’hui ceci et j’ai envoyé les fichiers de projet sur le dépôt git distant. Il vous suffit donc de récupérer la dernière version pour enfin avoir un projet fonctionnel.
Désolé de ne pas avoir vu le soucis plus tôt, j’étais tellement persuadé qu’il s’agissait d’un soucis de config de Android Studio que je n’ai pas pensé à vérifier que vous aviez tous les fichiers.
Tenez moi au courant pour me dire si ça marche avec ces modifications :slight_smile:

#17

Bonjour, Je viens de tester avec la dernière version des fichiers sur GIT, ça ne marche pas mieux.
je ne peux pas utiliser les fichiers du cours.
Une idée ?