iPhone denied request

#1

Bonjour

Je n’arrive pas a executer mon appli , pourtant j’ai validé dans dans l’iPhone.

Si quelqu’un a une idée ?

merci pour votre aide,

#2

Le modèle d’Iphone n’ est pas compatible avec la version du SDK d’´Xcode, si je me souviens bien.

#3

Bonjour,

Ce problème est apparu la semaine dernière, sans doute à la suite d’une modification du côté de chez Apple ou d’un bug sur leurs serveurs. Sur le web, pas mal de développeurs sous Xcode se plaignent de ce problème. Cette erreur touche principalement les développeurs qui n’ont pas souscrit au programme développeur d’Apple. En attendant une correction du bug ou d’un éclaircissement de la situation de la part d’Apple, plusieurs solutions ont été proposées sur le web. Une des solutions est de décocher la case “debug executable” dans l’onglet Info de l’“edit scheme”.

je suis également touché par ce problème et pour pouvoir continuer de développer mon appli avant de souscrire au programme de développer, j’utilise cette solution de secours.

Laurent

1 Like
#4

Bonjour Laurent,

Merci pour ta reponse , pourrais-tu me guider pour trouver la case à décocher SVP.

Merci pour ton aide

#5

Salut! Je suis aussi touché par ce problème depuis un moment et ai pas mal suivi les fils stackoverflow sur le problème… qui semble n’être toujours pas réglé.

Pour accéder à la fameuse case, dans Xcode, tout en haut à fauche de ton projet, clique sur le nom de ton appli qui se trouve juste à gauche de l’appareil choisi pour le simulateur. Va apparaître un menu avec entre autres “Edit scheme”, en bas. Une fois cliqué dessus, une nouvelle fenêtre d’ouvre. Dans l’onglet “Run”, il y a la fameuse case “Debug executable” qui apparaît!

Voila :slight_smile:

Une solution qui n’en est plus une : on ne peut plus lancer de debugage sur un appareil réel, obligé d’en passer par le simulateur…

Guillaume

1 Like
#6

Merci Guillaume pour ta réponse.

Une autre solution qui fonctionne également, est de laisser cocher la case “Debug executable” et de cliquer sur “Wait for executable to be launched”. A la compilation, l’app va s’installer sur l’iPhone comme auparavant. La seul différence est qu’il faut cliquer sur l’icône de l’app pour la lancer.

Laurent

#7

J’ai essayé cette solution mais je n’arrive tout de même pas à avoir un debugage… ou alors il y a quelque chose que j’ai loupé?

Merci!

Guillaume

#8

Hello les Amis,

Je tenais a vous remercier tous Laurent Guillaume Maxime et toute la bande car sans vous je ne suis pas grand chose en code. Mais ensemble nous sommes une sacré force ! Merci encore et que vive PurpleGiraffe !

Jean

#9

Bonsoir Guillaume,

Tu n’as rien loupé :slight_smile: Il y a effectivement bien un problème en cochant cette case pour lancer manuellement l’app. Le debugger ne peut fonctionner dû à un autre bug lié à cette option. Je n’avais pas vérifié avant de poster. Ce bug a été rapporté à Apple en juillet dernier. Je mets en lien l’url du site pour plus infos : https://blog.lickability.com/wait-for-executable-to-be-launched-2f8f72f2f6a

Laurent

#10

Bonsoir à tous,

Juste un message pour signaler que le problème semble être résolu. Depuis aujourd’hui
je peux recompiler mon app comme avant avec l’option débogage coché.

Laurent

1 Like
#11

Merci, je n’avais pas retenté depuis, mais ça semble fonctionner à nouveau pour mon projet également! :slight_smile:

#12

Ça a certainement été corrigé avec la mise à jour de XCode il y a 2 jours :+1:

#13

Ca a du être corrigé coté serveur plutôt, car je n’ai pas la nouvelle version de Xcode (10.2)… D’ailleurs étant bloqué à High Sierra avec mon vieux mac, je ne pourrai jamais l’avoir car elle demande Mojave… ça pourrait poser problème dans le futur, avec l’arrivée de Swift 5 etc…

#14

Yes, Swift 5 est arrivé.
J’ai fait la mise à jour de mon application et je commence à développer la nouvelle avec Swift 5.