Le nouveau Xcode 10.2 nécessite Mojave... Futur gros problème?

#1

Salut à tous!

Je viens d’essayer de mettre à jour ma version de XCode (10.1 et des brouettes) vers le nouveau 10.2, qui supporte notamment la version finale de Swift 5. Plutôt important du coup…

Cependant, mon mac datant de 2011 (macbook pro), je suis bloqué à High Sierra. Et Xcode 10.2 nécessite Mojave impérativement.

J’ai donc l’impression d’être bloqué à la version antérieure de Swift, à d’anciens SDK, ce genre de trucs…

Je ne dois pas être le seul à programmer avec un mac “ancien” mais qui fait tout à fait le job.

Est ce que selon vous ça risque d’être un problème à relativement court terme?

Guillaume

#2

Hello,

Je ne pense pas, car il y a quand même une bonne gestion des versions sur Swift.
Donc tu seras bloqué sur Swift 4 et tu ne pourras pas profiter des dernières évolutions du langage mais tu pourras toujours continuer à court terme.
C’est à long terme où ça peut devenir problématique, en fonction de tes projets ou autre.
Genre, si ils sortent une nouvelle fonctionnalité sur le Machine Learning, la réalité virtuelle ou autre, ils vont plus facilement le porter sur la dernière version du langage que sur les versions précédentes.

#3

Et pas de Xcode 11 non plus…
Ce qui veut dire aussi plus possible à l’avenir de publier une app sur le store… (comme depuis le début du mois de mars pour les versions d’xcode inférieures à 10)

Jc

#4

Il n’y a pas de version bêta de Xcode 10.2 B5 ?

#5

D’ici un an, après la sortie d’Code 11, tu ne pourras certainement plus soumettre d’applications sur le Store. Un renouvellement de machine s’impose (ou l’achat du cours sur Kotlin pour changer de crémerie …).

Je parle en conséquence de cause, il y a quelques années, j’ai dus acheter un MBPr pour remplacer mon vieux Mac Mini qui ne supportait plus la version d’OS nécessaire à Xcode.

#6

Le cours sur Kotlin est déjà acheté héhé :grin:.

Première « erreur » commise hier : j’ai passé mon iphone sous iOS 12.2 sans faire attention aux conséquences. Résultat, je ne peux plus débugger dessus, car plus compatible avec xcode 10.1… le simulateur au ralenti est donc maintenant mon unique solution :sob:

J’ai bien l’impression que je vais devoir finir par me résoudre à changer de mac… :money_with_wings: