Problème pub Admob

Bonjour à tous,

J’ai récemment créé une petite application qui est dispo sur l’App Store, et par la suite j’ai voulu la monétiser.
J’ai donc suivi un tuto pour rajouter de la pub via un identifiant publicitaire Admob.
Mon problème est que : lorsque que je teste mon application avec l’identifiant de démo, la pub s’affiche bien,
Mais lorsque je teste avec mon propre identifiant rien ne se passe…

Quelqu’un pourrait m’éclairer SVP :pray:
Merci d’avance,
Pierre

Bonjour Pierre,
je n’ai jamais utilisé admob mais vu ce que tu décris voici quelques pistes à explorer :

  • Est-ce que l’URL de configuration (s’il y en a une) est la même pour le mode test et pour le mode production ?
  • Est-ce que ton compte côté AdMob a bien été validé et autorisé à diffuser ?

Peut être que tu ne peux pas utiliser en mode débug les vrais pubs pour éviter de faire gonfler artificiellement tes revenus.
Il y a peut être un mode test qui marche en debug et un mode production qui ne marche qu’en production (apps compilées en release)

Salut !
Lors de ton test avec ton ID perso, tu l’as bien modifié dans ton GADBannerView addUnitID et dans ton fichier Info.plist ?

1 J'aime

Salut !

Oui, j’ai bien modifié les deux je ne comprend vraiment pas

Salut Max,

J’ai mis en ligne la version avec mon ID PUB sur l’App Store mais même en version définitive ça ne fonctionne pas :man_shrugging:

Mon compte Admob à l’air d’être autorisé

Je ne connais pas du tout AdMob :frowning: Ils n’ont pas un support technique que tu pourrais contacter ? Je pense que c’est lié à la config de ton compte d’une façon ou d’une autre

Salut Max,
J’ai réussit à contacter AdMob, c’était bien une information manquante qui empêchait mon compte de pouvoir afficher de la Pub.
Merci à toi :pray:

1 J'aime

Cool, content que tu aies réussi!