SafetyFirst - CocoaPods & Realm

Bonjour à tous,

En voulant faire l’application « SafetyFirst », j’ai un problème avec CocoaPods et Realm.

J’utilise XCode 12.1, sous MacOS 11.0.1, sur un MacBook Pro.

De ce que j’ai trouvé en farfouillant, CocoaPods n’est plus compatible avec mon environnement de développement…
J’ai essayé d’installer le framework Realm « à la main » mais je me perds dans les dépendances, la version à télécharger…

Je suis débutant sous iOS et ne suis pas encore familier avec l’utilisation de tous ces outils.

Merci de votre aide…

Salut @GregoireM

Essaye avec Swift Package Manager. Je te mets le lien d’un autre post, ou j’avais fait un mini tuto.

et pour Realm, c’est ça :

  • Add ‘realm-cocoa’ to your Project’s ‘Swift Packages’ section.
  • Input desired version.
  • Select ‘Realm’ and ‘RealmSwift’

Si, tu ne trouves pas realm-cocoa dans la liste, il faudra que tu connecte Xcode à ton compte GitHub, dans les préférences de Xcode et « Accounts ».

2 J'aimes

Bonsoir @anthonyfassler1,

Merci de ces explications, j’ai pu ajouter la référence à Realm et finaliser mon application.

Merci beaucoup !

2 J'aimes