Xcode-12 beta et Alamofire

Bonjour,
Est-ce que quelqu’un a déjà installé avec cocoapods alamofire sur un projet sur la version beta de xcode.
J’ai ce genre de problème. Il ne trouve pas Foundation.framework, Alamofire.framework.

Hello @slaverdu,

Est-ce que tu peux nous montrer le message d’erreur complet ?

Perso, pour certains Pods j’ai du spécifier une branche git spécifique pour Xcode 12 (le temps qu’ils release la version).

Bonne journée,

Alexandre

Vous avez essayé de regarder si vos dépendances ne sont pas compatibles avec Swift Package Manager ? Ca vous éviterait d’utiliser Cocoapods et ce serait bien plus simple

Merci pour vos réponses.
J’ai réussi l’installation en utilisant le terminal au lieu de cocoapods.

Ca serait intéressant d’avoir un petit cours éventuellement sur le Swift Package Manager.

A+

@slaverdu pas besoin de cours pour ça.

Il faut aller dans File/Swift Packages/Add Package Dependency…

Après tu copies et tu colles l’URL fournie par Alamofire (dans cet exemple)


Ensuite, tu choisis la version que tu veux.

Enfin, tu attends que ça s’installe et tu auras la dépendance dans la barre de gauche.

Fin du cours :wink:

4 J'aimes

Merci!
Super! intéressant. C’est certain que je vais l’utiliser…

Merci @anthony pour ce mini tuto!
J’ai prévu une vidéo à ce sujet dans le nouveau cours sur SwiftUI et sinon c’est déjà dispo dans le cours sur les nouveautés de iOS 13 et Swift 5 dispo depuis l’année dernière :slight_smile:

1 J'aime

Merci à vous deux.
Vraiment plus simple effectivement. Je n’avais pas suivi ce cours encore sur les nouveautés sur Swift 5. J’ai tendance à sauter quelques étapes car tout m’intéresse. J’adore ce que vous faites.

Il faut surtout aller chercher Xcode 12 def, qui est sorti hier ! :slight_smile: